CVE-2026-94250
Allocation of resources without limits or throttling vulnerability in batch-requests plugin in Apache APISIX. An unauthenticated caller can drive a gateway worker into OOM via a route where the batch-requests plugin is used and the batch endpoint is publicly exposed. This issue affects Apache APISIX: from 1.3.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
- Score
- CVSS 4.0 8.2 High
- Status
- Deferred - security@apache.org
- Published
- 2026-10-01
- Last modified
- 2026-10-01
- Weaknesses
- CWE-770
Affected products
References
- https://lists.apache.org/thread.html/l7o9w8pw3w3f12vf9ybm7xtfzoo6qct4
- http://www.openwall.com/lists/oss-security/2026/10/01/6