CVE-2026-86248

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.25, from 10.1.22 through 10.1.59, from 9.0.92 through 9.0.121. Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.

Score
CVSS 3.1 9.8 Critical
Status
Awaiting Analysis - security@apache.org
Published
2026-09-23
Last modified
2026-09-23
Weaknesses
CWE-287

Affected products

References