CVE-2026-86243
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
- Score
- CVSS 3.1 7.5 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-09-23
- Last modified
- 2026-10-06
- Weaknesses
- CWE-126
Affected products
References
- https://lists.apache.org/thread/8p4jf02w54m22x0cwpq2x53w3ov8o557
- http://www.openwall.com/lists/oss-security/2026/09/23/31