CVE-2026-77147
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
- Score
- CVSS 3.1 6.5 Medium
- Status
- Deferred - security@apache.org
- Published
- 2026-09-14
- Last modified
- 2026-09-14
- Weaknesses
- CWE-94
Affected products
References
- https://lists.apache.org/thread/qr464o2lyj3rxp8b0q25ssn0qwjxyrgz
- http://www.openwall.com/lists/oss-security/2026/09/14/15