CVE-2026-75880

An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes this issue.

Score
CVSS 3.1 6.5 Medium
Status
Analyzed - security@apache.org
Published
2026-09-10
Last modified
2026-09-18
Weaknesses
CWE-1333

Affected products

References