CVE-2026-75845
ArcadeDB versions 26.4.2 through 26.7.3 contain an authorization bypass vulnerability in the set_server_setting MCP server-level tool. SetServerSettingTool.execute() gates only on the global allowAdmin flag and never checks the caller's role, so in an MCP deployment with allowAdmin=true and a non-root allowedUsers set, any authenticated read-only user can invoke set_server_setting to modify server GlobalConfiguration, enabling configuration tampering or denial of service. The issue is fixed in 26.8.1.
- Score
- CVSS 3.1 6.3 Medium
- Status
- Deferred - disclosure@vulncheck.com
- Published
- 2026-08-18
- Last modified
- 2026-10-22
- Weaknesses
- CWE-269
Affected products
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-pff6-hp53-pj54
- https://www.vulncheck.com/advisories/arcadedb-before-authorization-bypass-via-set-server-setting