CVE-2026-68571

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. Special parameter in JDBC URL can lead to code injection.  Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.

Score
CVSS 3.1 8.8 High
Status
Awaiting Analysis - security@apache.org
Published
2026-10-16
Last modified
2026-10-19
Weaknesses
CWE-94

Affected products

References