CVE-2026-67590
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Score
- CVSS 3.1 7.5 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-08-05
- Last modified
- 2026-10-24
- Weaknesses
- CWE-674
Affected products
References
- https://lists.apache.org/thread/kmov6k7f3moqy01m1s370fl61vgos3ly
- http://www.openwall.com/lists/oss-security/2026/08/04/29