CVE-2026-63041

Reliance on Untrusted Inputs in a Security Decision vulnerability in Apache APISIX. This vulnerability allows an attacker to escalate privilege or perform an authorization bypass by sending certain values that the attach-consumer-label plugin does not sanitise correctly. This issue affects Apache APISIX: from 3.11.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Score
CVSS 3.1 8.8 High
Status
Analyzed - security@apache.org
Published
2026-08-26
Last modified
2026-08-26
Weaknesses
CWE-807

Affected products

References