CVE-2026-59878
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
- Score
- CVSS 3.1 7.5 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-07-28
- Last modified
- 2026-07-28
- Weaknesses
- CWE-20
Affected products
- Activemq (Apache)
- Activemq All (Apache)
- Activemq Amqp (Apache)
- Apache Activemq (Apache Software Foundation)
- Apache Activemq All (Apache Software Foundation)
- Apache Activemq Amqp (Apache Software Foundation)
References
- https://lists.apache.org/thread/dnyx4d2oldshcj4lthso7b53y4bqmjvn
- http://www.openwall.com/lists/oss-security/2026/07/27/7