CVE-2026-56091
When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause an authentication bypass. This vulnerability is similar to https://www.cve.org/CVERecord?id=CVE-2020-1957 https://www.cve.org/CVERecord , except that it affects the `shiro-guice` module instead of the `shiro-spring` module. This issue affects all Apache Shiro versions through 2.x, and 3.0.0-alpha-1 only when using `shiro-guice` module in a web servlet context. Upgrade to version 3.0.0 or later, which fixes the issue.
- Score
- CVSS 4.0 8.2 High
- Status
- Deferred - security@apache.org
- Published
- 2026-06-25
- Last modified
- 2026-10-25
- Weaknesses
- CWE-289
Affected products
References
- https://lists.apache.org/thread/onmtxmy2qonbpx7xlw3o34x8sctv47r7