CVE-2026-49872
Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Score
- CVSS 3.1 8.1 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Weaknesses
- CWE-287
Affected products
References
- https://lists.apache.org/thread/bzjpo60ygxo7kxdqf7vw3l5zw2lh6m5k
- http://www.openwall.com/lists/oss-security/2026/06/19/15