CVE-2026-49871
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Score
- CVSS 3.1 9.3 Critical
- Status
- Analyzed - security@apache.org
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Weaknesses
- CWE-352
Affected products
References
- https://lists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp
- http://www.openwall.com/lists/oss-security/2026/06/19/14