CVE-2026-49231
Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Score
- CVSS 3.1 5.4 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Weaknesses
- CWE-290
Affected products
References
- https://lists.apache.org/thread/s1jd1vxm59p6ghx47xhmpjdk1cobo4hn
- http://www.openwall.com/lists/oss-security/2026/06/19/13