CVE-2026-49230
Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass. This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Score
- CVSS 3.1 9.1 Critical
- Status
- Analyzed - security@apache.org
- Published
- 2026-06-19
- Last modified
- 2026-10-25
- Weaknesses
- CWE-354
Affected products
References
- https://lists.apache.org/thread/n0blgkpvz38ghh5rrh6wtl476919xj1b
- http://www.openwall.com/lists/oss-security/2026/06/19/12