CVE-2026-49042

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Score
CVSS 3.1 7.3 High
Status
Analyzed - security@apache.org
Published
2026-07-06
Last modified
2026-10-25
Weaknesses
CWE-20

Affected products

References