CVE-2026-48144
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
- Score
- CVSS 4.0 9.1 Critical
- Status
- Analyzed - security@apache.org
- Published
- 2026-07-27
- Last modified
- 2026-10-24
- Weaknesses
- CWE-297
Affected products
References
- https://lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9
- https://lists.apache.org/thread/2xoltfxgzf5jyhcwq6y07spts5cn6ppj
- http://www.openwall.com/lists/oss-security/2026/07/24/35