CVE-2026-47770
jq is a command-line JSON processor. Prior to 1.8.2, comparing two sufficiently deeply nested arrays with the == operator exhausts the C stack on jq's ordinary command-line surface, resulting in denial of service via stack exhaustion (uncontrolled recursion). The crash occurs in jq's recursive structural comparison code, with the recursion repeating through jvp_array_equal() and jv_equal() in src/jv.c when comparing deeply nested arrays; a nearby sort comparator path through jv_cmp() in src/jv_aux.c overflows the stack at a larger nesting depth from the same missing recursion guard. Anyone running jq comparisons on attacker-controlled deeply nested JSON values, or embedding jq in a context where untrusted data can reach the == comparison path, is affected. This vulnerability is fixed in 1.8.2.
- Score
- CVSS 4.0 6.8 Medium
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-06-25
- Last modified
- 2026-10-25
- Weaknesses
- CWE-674
Affected products
References
- https://github.com/jqlang/jq/security/advisories/GHSA-3pgx-frr7-3jxp