CVE-2026-47759
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
- Score
- CVSS 3.1 8.7 High
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-05-28
- Last modified
- 2026-10-14
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/tinymce/tinymce/security/advisories/GHSA-q742-qvgc-gc2f
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overview