CVE-2026-47339

Incorrect Authorization vulnerability in Apache APISIX. An attacker can capitalise on authz-casdoor plugin under default configuration to authenticate themselves with credentials from a different source. This issue affects Apache APISIX: from 2.14.1 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Score
CVSS 3.1 8.1 High
Status
Analyzed - security@apache.org
Published
2026-06-19
Last modified
2026-10-26
Weaknesses
CWE-863

Affected products

References