CVE-2026-46452

Improper Input Validation vulnerability in Apache NimBLE in Mesh Proxy SAR reassembly could result in passing broken data toward application resulting in memory pressure and unstable parsing behavior. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Score
CVSS 3.1 5.3 Medium
Status
Analyzed - security@apache.org
Published
2026-07-24
Last modified
2026-10-24
Weaknesses
CWE-20

Affected products

References