CVE-2026-45815
Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser. Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
- Score
- CVSS 3.1 7.5 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-07-24
- Last modified
- 2026-10-24
- Weaknesses
- CWE-617
Affected products
References
- https://github.com/apache/mynewt-nimble/commit/fae6a4874309ba0175d2c444e20f8a6bde007425
- https://lists.apache.org/thread/3d09hgo5zmm7dnryst3tb9857hk1bbos
- http://www.openwall.com/lists/oss-security/2026/07/24/14