CVE-2026-45802
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.
- Score
- CVSS 4.0 6.0 Medium
- Status
- Deferred - security-advisories@github.com
- Published
- 2026-06-11
- Last modified
- 2026-10-26
- Weaknesses
- CWE-400, CWE-770
Affected products
References
- https://github.com/Setasign/FPDI/security/advisories/GHSA-2mgw-7q6p-8grg
- https://github.com/Setasign/FPDI/commit/1695cfcc7e01fe844a7296b3de90855a3fa65be6
- https://github.com/Setasign/FPDI/releases/tag/v2.6.7