CVE-2026-45205

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Score
CVSS 3.1 5.3 Medium
Status
Analyzed - security@apache.org
Published
2026-05-14
Last modified
2026-10-26
Weaknesses
CWE-674

Affected products

References