CVE-2026-44580
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
- Score
- CVSS 3.1 6.1 Medium
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-05-13
- Last modified
- 2026-10-26
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h