CVE-2026-44444
Lumiverse is a full-featured AI chat application. Prior to 0.9.7, the Spindle extension build pipeline calls bun install without the --ignore-scripts flag before running the static backend safety scan (assertSafeBackendBundle). A malicious extension that ships a package.json with a preinstall, postinstall, or prepare lifecycle script achieves host-level code execution the moment an admin presses Install before any dist file is inspected. This vulnerability is fixed in 0.9.7.
- Score
- CVSS 3.1 9.1 Critical
- Status
- Deferred - security-advisories@github.com
- Published
- 2026-05-26
- Last modified
- 2026-05-27
- Weaknesses
- CWE-78
Affected products
References
- https://github.com/prolix-oc/Lumiverse/security/advisories/GHSA-8x98-3wjp-pmj9