CVE-2026-44046
Use of Less Trusted Source vulnerability in Apache APISIX. Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules. This issue affects Apache APISIX: from 1.2.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Score
- CVSS 3.1 5.8 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Weaknesses
- CWE-348
Affected products
References
- https://lists.apache.org/thread/xkshmps51b24yw0qckl5h5ddyv0x6qf9
- http://www.openwall.com/lists/oss-security/2026/06/19/6