CVE-2026-43869

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Score
CVSS 3.1 7.3 High
Status
Modified - security@apache.org
Published
2026-05-05
Last modified
2026-10-26
Weaknesses
CWE-295, CWE-297

Affected products

References