CVE-2026-42842
The form plugin for Grav adds the ability to create and use forms. Prior to 9.1.0, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Grav CMS Form plugin's select field template. Taxonomy tag and category values are rendered with the Twig |raw filter in the admin panel, bypassing the global autoescape protection. An editor-level user can inject arbitrary JavaScript that executes in any administrator's browser session when they view or edit any page in the admin panel. This vulnerability is fixed in 9.1.0.
- Score
- CVSS 3.1 5.4 Medium
- Status
- Deferred - security-advisories@github.com
- Published
- 2026-05-11
- Last modified
- 2026-10-26
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/getgrav/grav/security/advisories/GHSA-c2q3-p4jr-c55f
- https://github.com/getgrav/grav-plugin-form/commit/6bffb4c98be468a155d1656544ec45bb4a443957