CVE-2026-42797
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
- Score
- CVSS 3.1 4.9 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2026-05-25
- Last modified
- 2026-05-26
- Weaknesses
- CWE-202
Affected products
References
- https://lists.apache.org/thread/5y7d277sntyytrmxnx2tfjr9ftcpq1s6
- http://www.openwall.com/lists/oss-security/2026/05/25/5