CVE-2026-42536

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Score
CVSS 3.1 7.5 High
Status
Modified - security@apache.org
Published
2026-06-08
Last modified
2026-09-14
Weaknesses
CWE-120, CWE-122

Affected products

References