CVE-2026-42509

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Score
CVSS 3.1 6.1 Medium
Status
Modified - security@apache.org
Published
2026-05-06
Last modified
2026-10-26
Weaknesses
CWE-79

Affected products

References