CVE-2026-41501
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-05-08
- Last modified
- 2026-05-08
- Weaknesses
- CWE-77
Affected products
References
- https://github.com/electerm/electerm/commit/59708b38c8a52f5db59d7d4eff98e31d573128ee
- https://github.com/electerm/electerm/releases/tag/v3.3.8
- https://github.com/electerm/electerm/security/advisories/GHSA-8x35-hph8-37hq