CVE-2026-40976
In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.
- Score
- CVSS 3.1 9.1 Critical
- Status
- Modified - security@vmware.com
- Published
- 2026-04-28
- Last modified
- 2026-07-15
- Weaknesses
- CWE-305, CWE-862
Affected products
- Amq Broker (Redhat)
- Amq Clients (Redhat)
- Apache Camel Hawtio (Redhat)
- Camel Spring Boot (Redhat)
- Enterprise Linux (Redhat)
- Jboss Data Grid (Redhat)
- Jboss Enterprise Application Platform (Redhat)
- Jboss Enterprise Bpms Platform (Redhat)
- Jboss Fuse (Redhat)
- Jbosseapxp (Redhat)
- Openshift Devspaces (Redhat)
- Optaplanner (Redhat)
- Red Hat Single Sign On (Redhat)
- Spring Boot (Spring)
- Spring Boot (Vmware)
References
- https://spring.io/security/cve-2026-40976
- https://access.redhat.com/security/cve/CVE-2026-40976
- https://bugzilla.redhat.com/show_bug.cgi?id=2463322
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40976.json