CVE-2026-40046
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.
- Score
- CVSS 3.1 7.5 High
- Status
- Awaiting Analysis - security@apache.org
- Published
- 2026-04-09
- Last modified
- 2026-10-26
- Weaknesses
- CWE-190
Affected products
- Apache Activemq (Apache Software Foundation)
- Apache Activemq All (Apache Software Foundation)
- Apache Activemq Mqtt (Apache Software Foundation)
References
- https://www.cve.org/CVERecord?id=CVE-2025-66168
- https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt
- https://lists.apache.org/thread/zdntj5rcgjjzrpow84o339lzldy68zrg