CVE-2026-39999
Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.
- Score
- CVSS 3.1 9.1 Critical
- Status
- Analyzed - security@apache.org
- Published
- 2026-06-19
- Last modified
- 2026-10-25
- Weaknesses
- CWE-290
Affected products
References
- https://lists.apache.org/thread/nfopt8cnxd3k0rs1oxtr7lzxrdw4mojq
- http://www.openwall.com/lists/oss-security/2026/06/19/5