CVE-2026-39998
Improper Input Validation vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Score
- CVSS 3.1 8.8 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Weaknesses
- CWE-20
Affected products
References
- https://lists.apache.org/thread/vgkvy396010d7g6m0jrn4d3hjf2svlvv
- http://www.openwall.com/lists/oss-security/2026/06/19/4