CVE-2026-34356

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie* This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Score
CVSS 3.1 7.5 High
Status
Analyzed - security@apache.org
Published
2026-06-08
Last modified
2026-06-08
Weaknesses
CWE-122

Affected products

References