CVE-2026-33804

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

Score
CVSS 3.1 9.1 Critical
Status
Analyzed - ce714d77-add3-4f53-aff5-83d477b104bb
Published
2026-04-16
Last modified
2026-04-16
Weaknesses
CWE-436

Affected products

References