CVE-2026-33539
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.59 and 9.6.0-alpha.53, an attacker with master key access can execute arbitrary SQL statements on the PostgreSQL database by injecting SQL metacharacters into field name parameters of the aggregate $group pipeline stage or the distinct operation. This allows privilege escalation from Parse Server application-level administrator to PostgreSQL database-level access. Only Parse Server deployments using PostgreSQL are affected. MongoDB deployments are not affected. This issue has been patched in versions 8.6.59 and 9.6.0-alpha.53.
- Score
- CVSS 4.0 8.6 High
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-03-24
- Last modified
- 2026-03-26
- Weaknesses
- CWE-89
Affected products
References
- https://github.com/parse-community/parse-server/commit/03249f9bf5b8783c8b848f84dab791ff0b761b8c
- https://github.com/parse-community/parse-server/commit/bdddab5f8b61a40cb8fc62dd895887bdd2f3838e
- https://github.com/parse-community/parse-server/pull/10272
- https://github.com/parse-community/parse-server/pull/10273
- https://github.com/parse-community/parse-server/security/advisories/GHSA-p2w6-rmh7-w8q3