CVE-2026-31908
Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
- Score
- CVSS 3.1 9.1 Critical
- Status
- Analyzed - security@apache.org
- Published
- 2026-04-14
- Last modified
- 2026-10-26
- Weaknesses
- CWE-75
Affected products
References
- https://lists.apache.org/thread/sob643s5lztov7x579j8o0c444t36n6b
- http://www.openwall.com/lists/oss-security/2026/04/14/3