CVE-2026-31377
An Improper Authentication vulnerability in the Apache Doris Frontend (FE) meta service allows an unauthenticated remote attacker to access internal metadata service endpoints. The affected endpoints relied on client-supplied node information for authentication without providing sufficient authentication of the requesting party. Under certain network configurations, a remote attacker may be able to bypass the intended access control and access internal FE metadata interfaces, potentially exposing sensitive cluster information. This issue affects Apache Doris: from 2.0.0 through 2.0.*, from 2.1.0 through 2.1.*, from 3.0.0 through 3.0.*, from 3.1.0 through 3.1.*, from 4.0.0 before 4.0.8, and from 4.1.0 before 4.1.4. Versions 1.2.x and earlier are not affected by this header-trust vulnerability. Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4), which fixes the issue.
- Score
- CVSS 3.1 7.5 High
- Status
- Awaiting Analysis - security@apache.org
- Published
- 2026-09-23
- Last modified
- 2026-09-23
- Weaknesses
- CWE-287
Affected products
References
- https://lists.apache.org/thread/rf4ocqmzxvnwnxpsooj2lkzjl68b1m9q
- http://www.openwall.com/lists/oss-security/2026/09/23/10