CVE-2026-30911

Apache Airflow versions 3.1.0 through 3.1.7 missing authorization vulnerability in the Execution API's Human-in-the-Loop (HITL) endpoints that allows any authenticated task instance to read, approve, or reject HITL workflows belonging to any other task instance. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Score
CVSS 3.1 8.1 High
Status
Analyzed - security@apache.org
Published
2026-03-17
Last modified
2026-03-17
Weaknesses
CWE-862

Affected products

References