CVE-2026-30778

The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL. This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0. Users are recommended to upgrade to version 10.4.0, which fixes the issue.

Score
CVSS 3.1 7.5 High
Status
Analyzed - security@apache.org
Published
2026-04-15
Last modified
2026-10-26
Weaknesses
CWE-202

Affected products

References