CVE-2026-29146

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Score
CVSS 3.1 7.5 High
Status
Modified - security@apache.org
Published
2026-04-09
Last modified
2026-10-26
Weaknesses
CWE-1240, CWE-209, CWE-642

Affected products

References