CVE-2026-28780

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Score
CVSS 3.1 9.8 Critical
Status
Modified - security@apache.org
Published
2026-05-05
Last modified
2026-09-14
Weaknesses
CWE-122, CWE-787

Affected products

References