CVE-2026-27121
svelte performance oriented web framework. Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. This vulnerability is fixed in 5.51.5.
- Score
- CVSS 3.1 5.4 Medium
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-02-20
- Last modified
- 2026-02-23
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/sveltejs/svelte/security/advisories/GHSA-f7gr-6p89-r883