CVE-2026-26929
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
- Score
- CVSS 3.1 6.5 Medium
- Status
- Modified - security@apache.org
- Published
- 2026-03-17
- Last modified
- 2026-03-17
- Weaknesses
- CWE-732
Affected products
References
- https://github.com/apache/airflow/pull/61675
- https://lists.apache.org/thread/g5o6khx83jwqvdyn0mlyb0krt35cs9ss
- http://www.openwall.com/lists/oss-security/2026/03/17/4