CVE-2026-26022
Gogs is an open source self-hosted Git service. Prior to version 0.14.2, a stored cross-site scripting (XSS) vulnerability exists in the comment and issue description functionality. The application's HTML sanitizer explicitly allows data: URI schemes, enabling authenticated users to inject arbitrary JavaScript execution via malicious links. This issue has been patched in version 0.14.2.
- Score
- CVSS 3.1 8.7 High
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-03-05
- Last modified
- 2026-03-10
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/gogs/gogs/commit/441c64d7bd8893b2f4e48660a8be3a7472e14291
- https://github.com/gogs/gogs/pull/8174
- https://github.com/gogs/gogs/releases/tag/v0.14.2
- https://github.com/gogs/gogs/security/advisories/GHSA-xrcr-gmf5-2r8j