CVE-2026-24098

Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

Score
CVSS 3.1 6.5 Medium
Status
Analyzed - security@apache.org
Published
2026-02-09
Last modified
2026-03-10
Weaknesses
CWE-200

Affected products

References